Home   Forum   Classifieds   Tech/DIY   News   Articles   Chat   Contact Us

(1984 300GD) Speedometer works...Odometer? Not so much

Tech forum for DIY, repairs, restoration, problems, questions, etc... Post here get answers!
User avatar
Philbrownie
Posts: 52

(1984 300GD) Speedometer works...Odometer? Not so much

Post#1 » Sat Aug 01, 2020 3:29 am

Since I've owned the G, the odometer doesn't work (including trip meter), however the speedometer works fine (consistent, but about 4mph slow). It's the original VDO setup.

I may have missed a previous thread, but any advice on where to start to make it a functioning odometer?

Thanks!
1984 300GD LWB

alprazo
Posts: 75
Contact:

Re: (1984 300GD) Speedometer works...Odometer? Not so much

Post#2 » Sat Aug 01, 2020 4:26 am

I’ve use Palo Alto speedo twice. They have had parts in stock, turn around fast, threw in a couple of free bulbs, and got them both working for the same issue you have right now.

User avatar
G Nome
Posts: 4737

Re: (1984 300GD) Speedometer works...Odometer? Not so much

Post#3 » Sat Aug 01, 2020 5:48 am

Tire size could be affecting the speedometer. Palo Alto Speedometer can sell you part that will correct that while you are fixing it. They will need your tire size etc. It may be a certain % off if you pay attention closely.

Good luck.

Kent

User avatar
offroad-world
Posts: 8833
Contact:

Re: (1984 300GD) Speedometer works...Odometer? Not so much

Post#4 » Sat Aug 01, 2020 7:09 am

Philbrownie wrote:Since I've owned the G, the odometer doesn't work (including trip meter), however the speedometer works fine (consistent, but about 4mph slow). It's the original VDO setup.

I may have missed a previous thread, but any advice on where to start to make it a functioning odometer?

Thanks!


hi phil .

the speedo is always the same ratio , so it has nothing to do with the speedometer .
the speedo drive is mounted on the transfer case , on top of the cone are different numbers engraved which show the ratio , but it is very difficult to get out which is correct as the axle ratio and tire size are different , for example 300GD had 44/9 and a 250GD has 5.28 , different speed will be shown with the same speedo drive and same tire size . most speedo drives for big wheels are sold out , this is like #8 and #9 if i remember correct .

i hope that helps .

mfg. guido .

User avatar
offroad-world
Posts: 8833
Contact:

Re: (1984 300GD) Speedometer works...Odometer? Not so much

Post#5 » Sat Aug 01, 2020 7:18 am

Philbrownie wrote:Since I've owned the G, the odometer doesn't work (including trip meter), however the speedometer works fine (consistent, but about 4mph slow). It's the original VDO setup.


if you need a speedometer , let me know ;)

mfg. guido .
Attachments
IMG-20200726-WA0006.jpg

ilkkka
Posts: 6

Re: (1984 300GD) Speedometer works...Odometer? Not so much

Post#6 » Sat Aug 01, 2020 10:40 am

offroad-world wrote:if you need a speedometer , let me know ;)

mfg. guido .



https://www.ebay.co.uk/itm/MERCEDES-G-G ... 4672031114

990€ ???

User avatar
offroad-world
Posts: 8833
Contact:

Re: (1984 300GD) Speedometer works...Odometer? Not so much

Post#7 » Sat Aug 01, 2020 10:51 am

ilkkka wrote:
offroad-world wrote:if you need a speedometer , let me know ;)

mfg. guido .



https://www.ebay.co.uk/itm/MERCEDES-G-G ... 4672031114

990€ ???


yes , new they cost over 1000 euro at MB but they are sold out and as it shows never been again in production again . i have last 4 new ones , then i am dry on new ones also .
ebay asks 12% ebay fees , that is a lot of discount buying without ebay ;)

the speedometers in the box are used , not tested yet , so i sell them tested in a G and which are not working well i give to netherlands for repair .

mfg. guido .

User avatar
rpin
Posts: 222
Contact:

Re: (1984 300GD) Speedometer works...Odometer? Not so much

Post#8 » Sat Aug 01, 2020 2:54 pm

Philbrownie wrote:Since I've owned the G, the odometer doesn't work (including trip meter), however the speedometer works fine (consistent, but about 4mph slow). It's the original VDO setup.

I may have missed a previous thread, but any advice on where to start to make it a functioning odometer?

Thanks!


I have the same problem. Odometer recently quit. From my understanding it's most likely a plastic gear that commonly breaks (something to that effect). You might be able to DIY or send the whole thing to Palo Alto Speedo as mentioned or Hollywood Speedometer.

User avatar
Philbrownie
Posts: 52

Re: (1984 300GD) Speedometer works...Odometer? Not so much

Post#9 » Sat Aug 01, 2020 3:24 pm

offroad-world wrote:
Philbrownie wrote:Since I've owned the G, the odometer doesn't work (including trip meter), however the speedometer works fine (consistent, but about 4mph slow). It's the original VDO setup.

I may have missed a previous thread, but any advice on where to start to make it a functioning odometer?

Thanks!


hi phil .

the speedo is always the same ratio , so it has nothing to do with the speedometer .
the speedo drive is mounted on the transfer case , on top of the cone are different numbers engraved which show the ratio , but it is very difficult to get out which is correct as the axle ratio and tire size are different , for example 300GD had 44/9 and a 250GD has 5.28 , different speed will be shown with the same speedo drive and same tire size . most speedo drives for big wheels are sold out , this is like #8 and #9 if i remember correct .

i hope that helps .

mfg. guido .


Thanks Guido! That definitely helps explain why the speedometer is slightly off. I don't think I need a complete unit at this point, but get back with you if it's beyond repair. Thanks!

Phil
1984 300GD LWB

User avatar
Philbrownie
Posts: 52

Re: (1984 300GD) Speedometer works...Odometer? Not so much

Post#10 » Sat Aug 01, 2020 3:25 pm

alprazo wrote:I’ve use Palo Alto speedo twice. They have had parts in stock, turn around fast, threw in a couple of free bulbs, and got them both working for the same issue you have right now.


I think Palo Alto will be my first stop. Hope they ship to overseas addresses! Thank you!
1984 300GD LWB

Return to “G Wagen Technical Forum”

Who is online

Users browsing this forum: Baddy, cal_w460, Eisenhart, Fernando BR, Gpanzer, Johnny Christensen, Mercano, nbutze, PNZWGN, Winston, Yandex [Bot] and 21 guests