Home   Forum   Classifieds   Tech/DIY   News   Articles   Chat

Blower switch issue

Tech forum for DIY, repairs, restoration, problems, questions, etc... Post here get answers!
emoynier
Posts: 112

Blower switch issue

Post#1 » Thu Oct 12, 2017 6:25 am

I replaced the blower motor regulator and switch. But my fan motor is still ON in the 0 zero position.

Need advice on how to remedy this.

Here are pictures of the switch wiring, can some advise if all the wireing is correct.
Attachments
IMG_0385.JPG
IMG_0384.JPG
1997 W463 G300TD

User avatar
Chris
Posts: 1715

Re: Blower switch issue

Post#2 » Thu Oct 12, 2017 7:04 am

Do you have pics of wiring at regulator? That’s where mistakes can happen.

emoynier
Posts: 112

Re: Blower switch issue

Post#3 » Thu Oct 12, 2017 8:17 am

I will take picture
1997 W463 G300TD

emoynier
Posts: 112

Re: Blower switch issue

Post#4 » Fri Oct 13, 2017 7:12 am

Looks like the wires are in the right configuration.
Attachments
IMG_0388.JPG
1997 W463 G300TD

emoynier
Posts: 112

Re: Blower switch issue

Post#5 » Fri Oct 13, 2017 7:36 am

According to the wiring diagram all wires are in the right place. Maybe reverse the black wires.
Attachments
IMG_0389.JPG
1997 W463 G300TD

emoynier
Posts: 112

Re: Blower switch issue

Post#6 » Fri Oct 13, 2017 3:31 pm

I will check the continuity of the blue wire.
1997 W463 G300TD

Return to “G Wagen Technical Forum”

Who is online

Users browsing this forum: AmatoBGSG, bentrod, greynlds, PNZWGN, vectorsc and 15 guests