Home   Forum   Classifieds   Tech/DIY   News   Articles   Chat   Contact Us

Pics of my "new" 2000 Europa G500

Please introduce yourself here. A minimum of 3 posts here is required before you can post to the rest of the board.
Gelenwagen
Posts: 10

Re: Pics of my "new" 2000 Europa G500

Post#11 » Fri Sep 21, 2018 10:44 pm

Thats a great looking classic, congrats on the purchase!

User avatar
Leitkreuz
Posts: 237

Re: Pics of my "new" 2000 Europa G500

Post#12 » Sat Sep 22, 2018 12:11 am

That's an amazing find!
People who aren't familiar with quality will chase quantity

bart1
Posts: 48

Re: Pics of my "new" 2000 Europa G500

Post#13 » Fri Oct 12, 2018 11:37 am

It's been a rocky start. It's broken and been down for a few weeks. Waiting parts from Germany...

User avatar
Chris
Posts: 2579

Re: Pics of my "new" 2000 Europa G500

Post#14 » Fri Oct 12, 2018 9:32 pm

Details please- I’m always eager to learn about all issues these trucks caugh up...

User avatar
apple
Posts: 230

Re: Pics of my "new" 2000 Europa G500

Post#15 » Fri Oct 12, 2018 10:51 pm

Beautiful truck, unfortunate about the immediate issues.

Guessing it's a '99 production date? You have the pre-facelift steering wheel and cluster.

bart1
Posts: 48

Re: Pics of my "new" 2000 Europa G500

Post#16 » Thu Nov 08, 2018 1:29 pm

Russ had it months before I was able to get it. Since I have gotten it I have replaced a few trim pieces and such, but have had a couple of real issues.

The reason it was down was because without any warning, one day I could not turn the key. I applied force in every direction, sprayed WD40 in it, etc - could not get it to move! Towed it to the dealer that Saturday and got an eye wateringly expensive quote to fix it. They diagnosed it as the tumbler assembly failing. They planned to replace steering column and all. I towed it to another mechanic and sent him parts. I bought a key and tumbler from Germany through Russ and an ignition lock through Vlad. All is well on that front now.

The other thing is I get a CEL about half the time I drive it. Usually it doesn't show any symptoms, but a few times I have developed a very bad miss. You can kill and recrank and while the light is usually still on, the miss will go away. The light will eventually go off. My mechanic checked it and it was giving a catalyst damage error. Everything physically is fine, so he thinks it's probably the ECM. I hope to find a used one to repair and try.

Also have a roof leak I have been trying to diagnose. One of my rear drains was stopped up and when Russ had my roof repainted, the partially painted over my dried up sunroof seal. I have a new one, but need my body shop to do it to properly take care of the paint.

So, a handful of aggravating issues.

User avatar
AlanMcR
Posts: 3373

Re: Pics of my "new" 2000 Europa G500

Post#17 » Thu Nov 08, 2018 2:36 pm

That "stuck key" is usually a stuck steering column lock that fails to retract the pin. Disable it by keeping the pin from extending and that problem goes away forever (new part or old).
Every pre-MBUSA W463 should have this fixed before you need a very expensive tow. If you don't do this and take your G into the wilderness then you are really asking for it. It can easily fail with the wheels turned making it nearly un-towable.
...Alan

bart1
Posts: 48

Re: Pics of my "new" 2000 Europa G500

Post#18 » Thu Nov 08, 2018 5:46 pm

My steering lock did not lock the wheel, but I still could not turn the key and had to tow. The tow trick had little dollies to put under the tires if he needed them.

User avatar
Otiswesty
Posts: 2437

Re: Pics of my "new" 2000 Europa G500

Post#19 » Thu Nov 08, 2018 8:15 pm

Bart, I had problems with the steering lock on my 1999 shortly after getting it. Tumbler issues are pretty basic too. There is a ton of info on the forums. If you ask for help, you could have fixed it yourself in less time than it took to get your tow completed and making phone calls to Vlad and Russ.
Don't be a stranger, many helpful and knowledgeable peeps here

There are common CEL faults, post what info you have in the tech forum here.
1999 G500, 1997 G300, 1983 280GE

bart1
Posts: 48

Re: Pics of my "new" 2000 Europa G500

Post#20 » Fri Nov 09, 2018 3:25 am

Thanks Otis. I’ll post up my cel.

Return to “New User Introductions”

Who is online

Users browsing this forum: Bobmog, Chris, inkblotz, Jkysh, mogwild, paulunm and 3 guests